This Forum Has Been Replaced. Please Visit Our New Forum At
Welcome To The Connected Business Community Forum.
0 votes

I have setup a database in community version which is working fine. 

I want to connect to this database using webservices. Web-services are working fine but when I try to connect from a client, I get the following message:

"Your copy of Connected Business is a Community Edition licence. The required database version is MS SQL 2012 or higher in any Express Edition. The system detected the use of a database outside this requirement there for your connection has been aborted."

The SQL version running on the server is Express edition of MS SQL 2012. 

What am I doing wrong here?


asked Sep 16, 2017 in System by Ilyas | 107 views

4 Answers

0 votes

I've asked someone from our development team to take a look at this post :)
answered Sep 16, 2017 by anonymous
0 votes
Hello Ilyas,

Do you mind pasting here the version number of your SQL Server 2012 Express please?  You can do this by loading SQL Management Studio and run SELECT @@VERSION.

answered Sep 17, 2017 by ramil.domingo (880 points)

Hi Ramil,

I have tried it on two servers:

I get the following from Windows 2016 server:


Microsoft SQL Server 2012 - 11.0.2100.60 (X64)   Feb 10 2012 19:39:15   Copyright (c) Microsoft Corporation  Express Edition (64-bit) on Windows NT 6.2 <X64> (Build 9200: ) (Hypervisor) 

I also tested by installing it on Windows 7 64bit: 

Microsoft SQL Server 2012 - 11.0.2100.60 (X64)   Feb 10 2012 19:39:15   Copyright (c) Microsoft Corporation  Express Edition (64-bit) on Windows NT 6.1 <X64> (Build 7601: Service Pack 1) (Hypervisor) 

In both case I have the same issue.



Have you configured your Web Services to connect to this instance of SQL Server Express?

Have you tried connecting to the same SQL Server via LAN connection instead of Web Services?  To isolate that both connection type fails for this SQL Server instance?
Also, when did you downloaded this version of Community Edition?
Hello Ilyas,

I went ahead and signed up again for a CE version from CB website and got the email to download both Server and Client installers for CE.  Then I created a new company database.  After that I tested connecting via LAN to check that I can connect to my new database on a SQL Server Express instance and I was able to do so.  Lastly, I configured my web services to connect to this new CE database and then restarted CB to connect to this web services.  I was able to login and use my newly created CE database via web services.


Hi Ramil,

After your comments, I uninstalled the installed CB and reinstalled the latest version. I then upgraded the existing database to latest version. on LAN it still worked fine but connecting via web-services I had the same issue. 

I then created a brand new database in the new install. Again, this worked fine on LAN but on Webservices, I had the same issue.

Below is the error i get at the client end:

Client end config file:

On the server end on LAN it works fine:

Webservices Config file:

Server side SQL server services. online one instance of SQL Express installed.

SQL server version:

So not sure what I am doing wrong. If I change the webservices to demo database, then remote client works fine.

I hope you can help


Instead of accessing from remote client via web-services, I tried logging into CB from the CB server using web-services. I tried both localhost and the public ip. In both cases I was able to login.

So it appears that the the problem only happens when I try to login on a remote client using web-services. 

When you tested, did you try it locally or from a remote client?

Hello Ilyas,

Do you mind sharing a screenshot of the configuration of your web services please?  If you are able to connect via LAN then there is no reason to fail in Web Services if both of their connections are correct.  Since validating against SQL Express edition for both connection protocols are one and the same.

Thank you.

Please see below web-server settings:

Web-services folder's web-config settings:

On the server, initially I accessed with localhost instead of public ip and it worked. then I changed localhost to the public ip and it still worked on the server. However on a remote client it gives the error.

Hi Ramil,
Did you find anything? Also, did you try your test environment from a remote client?

Hi Ilyas,

Yes, we did run some tests and were able to replicate the issue. We will coordinate this with the development team. Please keep posted. Thank you.
0 votes

Hi Ilyas,

We found the cause of this error. You need to enable "Named Pipes" and " TCP/IP" under your  Sql Server Configuration Manager > SQL Server Network Configuration. (see sample screenshot). This should enable the remote user to log in using the webservice URL.

answered Sep 21, 2017 by HarnieJanapin (600 points)
Unfortunately, it doesn't make any difference in my case. I had already enabled these options. If you like I can PM you a teamviewer code to check for yourself. Let me know.

Hi Ilyas,

Can you provide a screenshot of your SQL configuration manager? And yes, we can also get a teamviewer access please. Thank you.

I can't see an option to send you a PM. I have sent the teamviewer details to Ramil. Alternatively if you email me I will reply with details.

Hi Ilyas,

You can send an email directly to
I have emailed you the id and password.

Thanks. We got it.
Any more news on this?
Our developer is still working on this. Will follow up with them regarding this.
+1 vote
Hi Ilyas,

I delivered a patch thru email. Please check it out and manually apply the patch for now. This patch should be included in the upcoming release of CB 18.2. Thank you.
answered Sep 27, 2017 by HarnieJanapin (600 points)
Thanks, the solution worked.
134 questions
168 answers
370 users